• Live Stream

    Watch us on Twitch
  • Donate using PayPal

  • Team Speak - Join us!

    HappyDiggers TeamSpeak
    Lobby
    InsaneJ from 10.200.13.15:37766
    HappyDiggers ARK
    HappyDiggers TFC
    Idle - AFK
    VIP
    HappyDiggers Vanilla
    HappyDiggers AMP
    Gamma - 18+
    Super Secret Place
    Staff Idle
  • Recent Article Comments

    Marius49

    Classic Game. New Server. More Adventures! Starbound Joins HappyDiggers!

    Awesome! You've done a fantastic job setting up the servers Jiro! :cool: Go to last post

    Marius49 16th June 2019 10:34
    LegendOfAir

    Classic Game. New Server. More Adventures! Starbound Joins HappyDiggers!

    It's pretty exciting ;p Go to last post

    LegendOfAir 15th June 2019 19:46
    InsaneJ

    Classic Game. New Server. More Adventures! Starbound Joins HappyDiggers!

    Don't you just love it that we now have 3 physical servers we can use to host various games on like... Go to last post

    InsaneJ 15th June 2019 19:20
  • Time to update Java again


    Everybody who plays Minecraft, uses Java so listen up! Oracle today released the June 2013 Critical Patch Update for Java SE. This Critical Patch Update provides 40 new security fixes. 37 of these vulnerabilities are remotely exploitable without authentication.

    So.... update now or be destroyed!

    If you are running 64-bit Windows, you should use the 64-bit Java too. Get Java here: http://www.java.com/en/download/manual.jsp

    And as always, if you have Java enabled in your browser then disable it. You really don't want to run Java applets in your browser in most cases. It's a huge risk having Java enabled in your browser. If you don't know how to disable Java in your browser, here is how.


    *update*
    Added manual download page so you can choose the 64-bit version.

    .
    Comments 1 Comment
    1. InsaneJ's Avatar
      InsaneJ -
      Updated post to include the manual download page for Java. This is so you can download the 64-bit version of Java. You should really do this if you have 64-bit Windows.

      Just an FYI. The HappyDiggers AMP mod pack will give you out of memory errors if you use the 32-bit version. So it's really a requirement for that
    Untitled Document