• Live Stream

    Watch us on Twitch
  • Donate using PayPal

  • Team Speak - Join us!

    HappyDiggers TeamSpeak
    Lobby
    InsaneJ from 10.200.13.15:46580
    HappyDiggers ARK
    HappyDiggers TFC
    Idle - AFK
    VIP
    HappyDiggers Vanilla
    HappyDiggers AMP
    Gamma - 18+
    Super Secret Place
    Staff Idle
  • Recent Article Comments

    Marius49

    Classic Game. New Server. More Adventures! Starbound Joins HappyDiggers!

    Awesome! You've done a fantastic job setting up the servers Jiro! :cool: Go to last post

    Marius49 16th June 2019 10:34
    LegendOfAir

    Classic Game. New Server. More Adventures! Starbound Joins HappyDiggers!

    It's pretty exciting ;p Go to last post

    LegendOfAir 15th June 2019 19:46
    InsaneJ

    Classic Game. New Server. More Adventures! Starbound Joins HappyDiggers!

    Don't you just love it that we now have 3 physical servers we can use to host various games on like... Go to last post

    InsaneJ 15th June 2019 19:20
  • HappyDiggers AMP for Minecraft 1.6


    The HappyDiggers AMP mod pack is currently still based on Minecraft 1.5.2. We're excited to move on to Minecraft 1.6, but we're not quite there yet. A lot of mods haven't yet updated to 1.6.

    To get an idea on which mods we're waiting for, I've made a nifty Google doc detailing which mods have released a 1.6 version. You can read it here.

    We're probably not going to wait for all the mods to update. Currently we're waiting for Binnies mod, Forestry(and related mods), Minefactory Reloaded, Logistics Pipe, Railcraft, Rotary Craft, Redstone in Motion and Thermal Expansion.

    I'll try to update the list as I do updates on the mod pack, so the information may be slightly out of date. If you know of a mod that's updated already, just let me know
    Comments 4 Comments
    1. Sverf's Avatar
      Sverf -
      Wondering what kind of launcher will we use for testing? Is there a multiMC version for 1.6.x minecraft yet?
    1. InsaneJ's Avatar
      InsaneJ -
      Not yet that I know of. It's the same for the FTB launcher though, they don't support 1.6 yet either.

      The community has to catch up with all the changes Mojang is making to Minecraft every time they bring out a new release.
    1. Marius49's Avatar
      Marius49 -
      Well Mojang said they want to make modding much easier but it looks like 1.6 brought the opposite to it from what I see...
    1. InsaneJ's Avatar
      InsaneJ -
      The mod API should have been present from day-1. Because it wasn't people just started hacking the jar file and things like Bukkit and Forge were born to make it easier for modders.

      If Mojang ever does make a mod API, it should be close or even compatible with Bukkit and Forge. If it's not, then all the mods will have to be rewritten in order to work.

      That's going to be a real shit-storm. It will further fragment the modding community if you ask me.
    Untitled Document