Results 1 to 6 of 6
  1. #1

    Taking damage at log on

    When trying to log on this morning, my avatar kept moving erratically without me touching the mouse. With the last attempt to log in, I was actually taking damage like I was being buried (and I was just standing in my hut). I believe I was able to disconnect before dying. Also, the dynmap is not loading town boundaries.
    Last edited by PauletteP; 16th November 2015 at 15:21. Reason: additional note

  2. #2

    Angry Towny Error

    Quote Originally Posted by PauletteP View Post
    When trying to log on this morning, my avatar kept moving erratically without me touching the mouse. With the last attempt to log in, I was actually taking damage like I was being buried (and I was just standing in my hut). I believe I was able to disconnect before dying. Also, the dynmap is not loading town boundaries.

    ​yes there seems to be a Towny Error, it went into safe mode.

  3. #3
    Cake! InsaneJ's Avatar
    Join Date
    Jan 2012
    Location
    Cakeville
    Posts
    4,681
    Blog Entries
    21
    Yup, Towny managed to create a town without a mayor in the database again. This time it was the town of 'ggg' that caused the problem. I've removed the town and things seem back to normal now.

    If you guys need anything reimbursed, please use this thread:
    http://happydiggers.net/showthread.p...ment-%28TFC%29

  4. #4
    Quote Originally Posted by InsaneJ View Post
    Yup, Towny managed to create a town without a mayor in the database again. This time it was the town of 'ggg' that caused the problem. I've removed the town and things seem back to normal now.

    If you guys need anything reimbursed, please use this thread:
    http://happydiggers.net/showthread.p...ment-%28TFC%29
    I saw that town created last night. It nearly immediately fell into ruin (probably dropped by its mayor). You might want to see if there's a cooldown on town creation.

  5. #5
    Cake! InsaneJ's Avatar
    Join Date
    Jan 2012
    Location
    Cakeville
    Posts
    4,681
    Blog Entries
    21
    I don't have an issue with people creating a town and then dropping it right away. Perhaps they made a typo or saw a plot they liked better? But it shouldn't cause server problems, which it now sometimes does.

    I've come up with a possible solution. I'm now forcing the Town table in the database to not allow a Town record without a mayor and a resident. When a town is created it has a mayor who is also a resident there so it should work. I've created a Town with Mupje's MC account and it seems to work. Let's hope nothing breaks further down the line

  6. #6

    Thanks!

    Quote Originally Posted by InsaneJ View Post
    I don't have an issue with people creating a town and then dropping it right away. Perhaps they made a typo or saw a plot they liked better? But it shouldn't cause server problems, which it now sometimes does.

    I've come up with a possible solution. I'm now forcing the Town table in the database to not allow a Town record without a mayor and a resident. When a town is created it has a mayor who is also a resident there so it should work. I've created a Town with Mupje's MC account and it seems to work. Let's hope nothing breaks further down the line
    Thanks so much for all that you do

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •